My take on this topic is that, for me, the approach has not been nearly so complicated.

The Mac OS is a streamlined interface to a unix core and using that interface (i.e. "The OS") makes life "much more easier."

I have had no problem with CDHK going through my Mac to eventual use.

Stuffit Expander is free and works without my intervention producing the content I need to transfer to my flash cards.

The only caveat is this:

The Mac OS uses hidden files for the user interface. The presence of these files on flash media can (and do) interfere with the cameras' recognizing the presence of a "firmware update" and hence it will not load.

Now, it is possible to use a terminal window to delete these hidden files and eject the flash media, but a much simpler solution is to download (and eventually purchase) an excellent utility which manages the necessary unix options - "BlueHarvest" (

(Note: There are other such utilities, some free.)

This utility can be configured to perform automatically or manually.

My Mac has not been a hinderance to my using various CDHK dealies - in fact, it has been very easy.

I hope this helps.

MacGuy 22:58, 6 June 2008 (UTC)

errors with scripted installation Edit

(For help with errors, please post the error number and if possible the log file. This will greatly expedite the support process.)

mac os x 10.4.11 downloaded installations script, ran, and after a sec or two i get a error reading"you must unlock your SD card to install CHDK!" The SD card is unlocked. Not sure what to do after this. Help please.

same deal with me Edit

I've had no luck with either scripted method listed on the Mac faq page.

The error I get is:

You must unlock your SD card to install CHKD! Message: newfs_msdos: warning: /dev/ disk4s1 is not a character device newfs_msdos:226 clusters too few clusters for FAT16, need 4085; Number:1

nothing shows up in the Event Log other than 'stop'

--Jerry leach 21:31, January 10, 2010 (UTC)

error with scripted installation... Edit

The error you received is a result of an error in the initial try statement of the script. I can't give more specific information without the error number and more importantly the log file.

At the bottom of the ScriptEditor window is a button called Event Log. Please click it and run the script again. Then send along the contents, which will give clues to what is specifically going wrong.

You can also email me the results of the log for faster service. My email is in the Read Me file.

--Oooh 21:05, 29 March 2009 (UTC)

Automated transfer of Problem Report #20721 Edit

The following message was left by Anonymous via PR #20721 on 2009-04-08 17:52:36 UTC

There are popup windows for coupons for iPhone 3G accessories that spreads over parts of the article and can't be moved so parts of the article can't be read.

New CHDK prep script Edit

I had a minor issue with the provided AppleScript... I don't remember what... and like any good nerd I reinvented the wheel and wrote my own script. I'm rather pleased with the result so I'm adding it to the page.

It's a bash script, so running it pops open a Terminal window, but that shouldn't scare too many people. I tried to cover all problems (locked card, selecting boot device instead of card, etc) and I fully automated every step aside from installing CHDK files (since those vary with camera). It partitions the card with a small CHDK partition and a large CAMCARD partition (though you can input different names if you like). It hex-edits BOOTDISK into the boot sector if you want it to. It installs either ver.req and/or vers.req if you want it to.

It's fully tested on Leopard and Snow Leopard, so give it a try! Please report back with any issues because I'd love to improve it.

good script Edit

@cowboytronic: After trying the other scripts, I found yours to be quite straightforward and easy to follow.

Everything works fine and the card is bootable, the only problem is that the images are being saved to the CHDK partition, not the CAMCARD partition. This only gives me 12 MB of storage.

I ran through all the steps to prepare the SD card and then dragged both DISKBOOT.BIN and PS.FR into the "CHDK" directory. Locked the card and then inserted into the camera and booted w/o any problem.

Any tips on how to get around this issue?

CHDK version: allbest-ixus55_sd450-100c-50

Sorry, I don't know. When I accidentally leave my card unlocked the camera will boot normally and, of course, use the first partition. That will cause it to try to save files there, and it is small so it doesn't work well. But when I lock the card it works as I'd expect: boots CHDK and saves images to the 2nd partition. --cowboytronic

  • The Ixus 55 doesn't support SDHC cards, therefore there's no multi partition support implemented for this camera - CHDK can only use the first partition of a SD card.
    This said, the SD card should NOT be partitioned, use a single partition instead (FAT16 formatted & made bootable by having "BOOTDISK" at offset 40h).
    See also Bootable SD card: Mac. Fe50 06:09, 8 July 2009 (UTC)

Thank you for the info guys. The manual installation provided in the FAQ, was just curious to know if there was a script installer similar to cowboytronic's that might help others like me who are new to CHDK. Good to know it's an SD card issue with the IXUS 55 and not script. It took some time to learn about the differences between FAT16 and FAT32, but now it's dead easy to reformat to FAT 16.

Anyone ever tried to hack a larger battery to work with their Canon + CHDK? I think the Arduino would be great to do a mobile pan + time-lapse setup (mounted high on a street lamp somehow), but my 3.7V 760mAh battery life only gives me 2-3 hours and kind of hinders this application. --Spangaroo 07:10, 8 July 2009 (UTC)

the CHDK_prep script not working for me Edit

first, the 'yes' or 'no' thingy doesn't work if I inadvertently leave caps lock on. LOL. but that's not the issue.

I type yes, get a list of volumes. Mine is 4, so I enter 4.

I get the prompts for CHDK partition (I hit enter) and for CAMCARD partition (I hit enter)

I get the scary warning message. I type yes.

I get '16M does not appear to be a valid disk size' and 'I sure hope this is what you wanted!' with a prompt to hit RETURN to continue. I hit RETURN.

I type 'yes' to make the volume on disk4 bootable.

I type 4 to 'do nothing' (I know my ver #)

I get a happy shooting message.

nothing's been done to the SD card, no files put on it or anything. should I be running this script from a particular directory? or can I run it from the mounted disk.

I'm gonna put it into the directory with the files, see if that helps.. nope it doesnt.

I'm using the original 16M disk that cam with the camera instead of the 2gig that I use for photography.

Could that be the issue here? And I'm the one that listed the error message above, where the other script isn't working either. Are older 16meg SD cards not supported?

I'm using the latest snow leopard. Neither script works.

maybe tomorrow I'll try the whole manual thing with the hex editor and all that. I'm too burned out on this now to continue.

--Jerry leach 21:29, January 10, 2010 (UTC)

TheUnarchiver and quarantine attributes Edit

Despite the instructions, I find that TheUnarchiver 2.3 under Snow Leopard still sets the quarantine attribute. Plain old InfoZip 'unzip' does too. Scruss 15:16, January 17, 2010 (UTC)

snow leopard Edit

If I understand the discussions and the instructions, CHDK will not work with Snow Leopard. I have the latest version of Snow Leopard and can't really get anything to download. trekkerman174.51.113.72 22:40, March 3, 2010 (UTC)

  • Since CHDK is running on the camera, it's completey independent from the computer's OS. The downloads are available from the link on the Download page, also absolutely OS independent. To run CHDK, just download the correct package, unzip all files & folders to the card's root; on your Mac then you have to remove the quarantine flag (read here, i suggest the terminal method). This way you will be able to start CHDK manually with "Firmware Update..." from the Canon menu (start the camera in playback mode !). Fe50 06:27, March 4, 2010 (UTC)

Installed CHDK w/script, camera doesn't recognize memory card Edit

After looking at my card I realized that I snapped a corner off of my card within my card reader. So NM all. Thanks!

Problem with script chdk_prep.dmg Edit


I have a 4GB SD card.

I launched the script chdk_prep.dmg. It ran without problem, it created 2 partitions on the card, and finished by locking the card. Now my card is no more writeable using Mac. I can take pictures and they are stored on the card.

But I can't copy file on the card and I don't find the way how to modify the status of the card from readable to writeable.

Can anybody help me ?


CHDK_prep command on Lion OSX Edit

Runs like a charm - just change "if $OS_VERSION == 10 " to "if $OS_VERSION == 11".

Terminal? Edit

When it says mount the terminal I do not know 17:33, April 26, 2012 (UTC)

Remove xattr Edit

Untar and The Unarchiver both add the quarantine attribute, just like the default Archive utility.

The correct sytax to remove the quarantine attribute is:

xattr -d ./DISKBOOT.BIN ./PS.FI2

otherwise you will get a file not found error. At least under OS X 10.7.4.