Hello to those newbies like me. Here is where I shall document all my findings in using the Canon A570 IS with CDHK.

Step 1) Find out your camera's firmware. To do this, you'll have to create a file called "ver.req" (On a PC, you can use Notepad. Select "all files" under File Type and then ver.req. as the file name.) This will be a blank (zero-length) file. You can even make it in Windows File Explorer by right-clicking in any folder, click "new", click "text document", and rename the file "ver.req".

Then you have to get this file onto your SD card. If you have an SDHC card, but your card reader does not read SDHC cards, you could use an older card that is SD. Using a USB connection to transfer to a card installed in the camera might not work -- the Paste command is not available, at least not in windows XP.

After you get the file onto your card, put the SD card back in your camera. Set the camera to REVIEW mode, turn on the camera, depress the FUNC SET button and while it is down, also the DISP button. The display that appears will include a line something like: Firmware Ver GM1.01A.

Step 2) Download the software. Now that you know the firmware version (you wrote it down, right?), take the card out of the camera again, plug it back into the computer, click here and read the chart to figure out which build (version) you can use. Download the build you want, unzip it, and copy the files onto your SD card. Put the card back in your camera. You may have to take 1 picture (I did) the first time you set this up. Then go back into REVIEW mode, click the MENU button, look for "Firmware Update", and click it. THIS DOES NOT REALLY UPDATE YOUR FIRMWARE. This is a temporary upgrade. To go back to using your camera the old-fashioned way, take the card out and delete the software files. Go back to RECORD mode and you're ready to rock.

Step 3) Exploring your Super A570 IS. I'm currently only familiar with the AllBest50 build (If I ever get around to using other ones, I'll add them to this page). The PRINT button is what's known as the <ALT> MODE button for the A570. To have fun with your new software, click the ALT (PRINT) button. The bottom of the screen should say "Default Script" and "ALT". Now some of your camera buttons will work differently. The MENU button will pull up the CHDK Menu. Use your arrow buttons to navigate it (naturally). Go to this page to read about a lot of the preferences and features (some features may not be included with your build).

AllBest50 has given me a clock, calendar, Reversi (for when I'm bored), shutter bracketing, focus bracketing, scripting, live histogram, file browser, and the greatest gift of all... BATTERY POWER EXPRESSED IN PERCENT!!! My biggest annoyance with the A570 (and I'm sure there are other similar models) is never knowing when the damn flashing battery icon is gonna die. Now I know. Thank you CHDK Builders.

And you can overide all kinds of things like shutter speed, aperture, ISO, auto ISO...

As for RAW files, you can set it to take them but since we are technically cheating, Photoshop, Lightroom, and Bridge don't recognize the files it creates in RAW. I've had to use GIMP 2 and the UFRaw plug-in. Both are free to use and it will open your new RAW files. I haven't played with the software enough yet, so I can't brag about it just yet.

I still have to explore USB remote control (I can't wait), RAW files more, and the scripting. I haven't taken any pictures of lightening yet but that is one of my goals.

More to follow...

TenTen71 05:33, 22 August 2008 (UTC)

I will try to document the A570IS.

I have tested the progeam found at [1], and found that it it much better at devoloping raw shots than the other methods I have tried, including a previous edition of dng4ps that did not include A570 support although it "worked" using A720 settings. It is also IMHO superior to raw therapy or Picasa, which also worked.--Ke7doy 02:39, 31 January 2008 (UTC)

Hi everyone!!! I have a canon powershot A570 IS 7.1 mp firmware it seems that I cannot change the startup screen and the sounds of it.... was wondering if it's possible for anyone to create a alt firmware for it so it can do what all other canon does????

thx for helping out!


I have the A570 IS also. I just tried each of the two versions available because the trick to find out the true firmware version does not seem to work on mine. I sounds like you have the same problem so the 101a should work. 03:53, 8 January 2008 (UTC) ke7doy at gmail dot com if you need help. I just download the 101a and just putting the files on the sd card sould work or am I missing something???

You have to turn on the camera in playback mode and use the menu to find firmware update then update. Then use the print button to access the chdk menu and choose make card bootable from the debug menu. Turn off the camera remove the card and lock it. Now when you turn the camera on the chdk will automaticly boot. Ke7doy 03:41, 11 January 2008 (UTC)

Couldn't figure out how to get things to work with the Uploader. Didn't find any 570's in there and was struggling to load the chdk. Luckily found an SD reader and the whole thing turned out to be very easy. The 101a was the existing firmware. I really like being able to see how much battery power is left though it seemed to be decreasing a bit too rapidly for my liking. Am now ready to try out some of the cooler features available :-)

Hello everyone. Posting about problem a have with CHDK 0.9.8-760. My camera is Powershot A570 IS 1.01a. Whenever I'm trying to take a series of bracketed shots with continuous bracketing, camera dies. It takes one shot, shows it in preview and just dies. I used tv bracketing, no RAW, just jpeg. Hope someone got solution --Bearrus 15:37, 12 May 2009 (UTC)

Can't see Firmware Update in menus Edit

I have done another camera, so I know what to do. I got the CHDK for this camera and firmware, and put them on the card. On this A570IS, turned on in playback with 1 picture on the card, I can't find Firmware Update on the menus. What could be wrong? 04:30, December 12, 2009 (UTC)KentD

Permissions fixed Edit

The Mac FAQ told me the problem. I have recently upgraded to 10.5, and the permissions were wrong on the files. 15:46, December 12, 2009 (UTC)KentD

Community content is available under CC-BY-SA unless otherwise noted.