Hum, not much for programming, but let me know if you need anything. I have one of these cameras and would be very interested in flashing it with new firmware. I added the ver.req file in the root of the camera's flash card and got this info: P-ID:3191 NT D; Firmware Ver GM1.00B; No Error; Aug 28 2008 15:15:05;; Adj Ver.008. 009;; Adj Ver.008. 009; IS Firm Ver. 3.00; IS Param Ver. 2.04

Senrich 04:45, 31 December 2008 (UTC)

awww snap[edit source]

Just got one of these, was hoping there'd be an available chdk. Digging through the help files trying to figure out how to port chdk to it. No experience with handling disassembled files though, hope the devs will get to this soon :]

CHDK on A2000[edit source]

pls pls help me to make chdk on a2000is its a excelent camera.i buyt specialy to chdk but never try to see if its any chdk for this model.......

Just make a simple chdk to display "Hello World" on the screen... The simple "Hello World" chdk would make me happy. And, forget about my poor English.

HELP!Interlanguage links[edit source]

I wanted to translate the CHDK wiki into Chinese. But when I added zh: below the codes of the main page, the text "zh:" displayed. How can I add an interlanguage link like the link to the Japanese CHDK wiki? HELP!

Not working on firmware v 1.00B[edit source]

Hi there,

I lept for joy when I saw that CHDK was available for my A2000IS. But despite this article stating it "should" work with v1.00B firmware, I get nothing on mine. I copied all files to the car, locked the card, and reloaded it into the camera - no differenve. Am I missing something?

My firmware actually shows up as "GM1.00B" - are the letteres GM significant?

Fingers crossed that it will work soon!

Thanks in advance for any help,


No, the GM prefix is on all firmwares. You've done something wrong. If the firmware version was incorrect, the symptom would be the camera crashing, or behaving incorrectly. Talk pages on this wiki are generally ignored, and are not the correct place to ask for support. I suggest reading the FAQ and the FAQ/Mac if you have a Mac. If you have further trouble, use the forum, starting with the newbies section. reyalp 02:01, November 27, 2009 (UTC)
Many thanks! It's GOOD news that the error is mine and that it might work if I try something different. I shall investigate. Thanks again, Skev

My camera broke down last night[edit source]

Forget about my poor English.

Yesterday I tried to use chdk's MF function. In alt mode, I pressed up and down button several times,and the value of "Subj. Disrt." changed between 65536 and 0. Then I rotated the zoom lever ,the MF function worked. Several minutes later , when I was looking around the chdk menu ,the camera's lcd went black and it said "lens error,please restart camera" in chinese. I just want to know if chdk caused the problem of the lens.Now the camera doesn't work. The lens goes in and out for several times after swich the camera on ,finally it displays "lens error,please restart camera".

Please help me.



It is possible that this was caused by CHDK. It is also possible that it was coincidence. If it was caused by CHDK, this would be the first time CHDK was known to cause damage like this. See FAQ#Q._Can_CHDK_damage_your_camera.C2.A0.3F. I'll post a link in the | A2000IS thread. Perhaps other uses will comment if they have used SD override without experiencing this. You may want to try removing the batteries from your camera for some time and then putting them back in and restarting. reyalp 06:24, February 23, 2010 (UTC)

            • I've got my camera repaired and it works quite well now. I thought CHDK had caused nothing because I disassembled the camera and found the lens FPC (a soft pcb that connects the pcb and the lens) had been resoldered. I used to throw and knock my camera :)*******
Community content is available under CC-BY-SA unless otherwise noted.